support Contact Support | system status System Status
Page Contents

    The Native SDK for Android will EOL support for ExoPlayer 1

    In July of 2019, the Brightcove Native SDK for Android will be removing support for ExoPlayer 1.

    Overview

    Google continues to update the ExoPlayer media player framework with the latest technology solutions. In order to focus on cutting edge features, we must evolve alongside Google by providing support for only the relevant version of the ExoPlayer.

    The ExoPlayer 1 release was last updated on March 17, 2017. If you haven't already done so, we recommend transitioning to the ExoPlayer2 framework.

    For details about how to migrate, see the Migrating to ExoPlayer 2 Framework document.

    Questions

    We understand that this is a technical topic and are happy to answer any questions concerning the transition. Please reach out to us through the SDK Developer Forums for technical questions, or to your account manager for concerns.


    Page last updated on 12 Jun 2020